401 cvc-enumeration-valid

NowyUzyt
Posty: 2
Rejestracja: 28 kwie 2014, o 23:01

Re: 401 cvc-enumeration-valid

Post autor: NowyUzyt » 28 kwie 2014, o 23:12

Witam,
Niestety programiści nie postarali się i nie używają znaków Unicode. Aby naprawić problem należy w panelu sterowania wybrać opcje regionalne a następnie zakładkę Administracyjne i zmienić ustawienia regionalne systemu na polski, aby to zadziałało to należy się wylogować i zalogować ponownie, po czym już będzie działać e-deklaracja. :-)

M.K.
Posty: 2754
Rejestracja: 9 gru 2009, o 10:53

Re: 401 cvc-enumeration-valid

Post autor: M.K. » 29 kwie 2014, o 09:11

A dlaczego "e-deklaracja" nie będzie działać?

NowyUzyt
Posty: 2
Rejestracja: 28 kwie 2014, o 23:01

Re: 401 cvc-enumeration-valid

Post autor: NowyUzyt » 29 kwie 2014, o 23:15

W moim przypadku plugin E-Deklaracje 4.0.0 jak i pewnie innym poległo właśnie na mapowaniu znaków. O ile XML który jest szyfrowany i wysyłany dalej jest kodowany w UTF-8 i wszystkie polskie znaki diakrytyczne zostały usunięte tak aplikacja w sama w sobie używa ustawień regionalnych i np. zamiast Danych autoryzujących mam w miejscu "ą" krzaczek. Jeżeli inne rozwiązania/aplikacje są oparte o tą samą bibliotekę co w tym pluginie to również mogą być podatne na ten problem.

M.K.
Posty: 2754
Rejestracja: 9 gru 2009, o 10:53

Re: 401 cvc-enumeration-valid

Post autor: M.K. » 30 kwie 2014, o 09:27

PITy 2013 właśnie napisałem w unicode ale... jednej z bibliotek, którą używam na razie nie udało mi się przerobić i to z jej powodu jeszcze to nieszczęsne ustawienie.

ODPOWIEDZ